mirror of
https://github.com/OpenBB-finance/OpenBB.git
synced 2026-10-28 13:01:38 +00:00
Python 3.10 reached end of life on 2026-10-01, and the patched releases of Pillow (13.0.0) and filelock (>=4.2.1) require Python >=3.11, so the 3.10 resolution fork kept vulnerable versions in every lockfile. - requires-python = ">=3.11,<4" in all pyproject.toml files, the cookiecutter template, and the CLI codegen project template - CI: drop the ubuntu 3.10 matrix rows, move the macOS/Windows minimum rows and the lint jobs to 3.11, drop 3.10 from the nox sessions - READMEs: state 3.11 as the minimum supported version